Excel - Dividere i dati di una colonna per tipologia

google-plus Scritto da . Postato in Excel

Excel è davvero un programma elastico e insostituibile. Quante sono le tipologie dei dati che trattate o gestite attraverso questo programma, così sono le possibilità che Excel vi da per poterli analizzare, dividere, unire e... qualunque cosa la vostra immaginazione vi fa pensare.

Qualche giorno fa, sempre dovendo esportare e importare dati da un gestionale all'altro, mi sono imbattuto in un'altra problematica: Una colonna, conteneva per alcuni fornitori, gli indirizzi email, per altri l'IBAN del fornitore.

Trattasi di 800 righe... eek Come fare a dividerli tutti senza doverlo fare a mano???

La colonna non era fatta per entrambi i dati, ma ahimé accettava entrambi i formati... E' ovvio che il problema era dovuto al fatto che il cliente non si fosse posto il problema di dover dare conformità ai dati inseriti per poi in un futuro rendere facile il lavoro di esportazione dei dati.

Dopo un attimo di sconforto, ho cercato nella rete e nell'help di Excel un qualcosa che potesse darmi una mano a suddividere i dati della colonna per tipologia su due colonne differenti, una dedicata agli IBAN e l'altra alle email.

  • La prima illuminazione, è stata che Excel permette attraverso alcune funzioni (RICERCA e CERCA.B), di cercare caratteri specifici all'interno di una determinata stringa di caratteri, o di una cella.
  • Il secondo pensiero, è caduto sulla funzione SE che permette di effettuare un'azione piuttosto che un'altra a seconda se la condizione è vera o falsa.
Per quanto riguarda la funzione RICERCA (quella cioé che cerca caratteri nella cella), è da tenere in considerazione che se non trova quello che che gli abbiamo indicato, come risultato restituisce un errore! (#VALORE).
  • Per ovviare a questa caratteristica, il terzo pensiero, è andato alla funzione SE.ERRORE che a seconda che la funzione RICERCA restitutisce un errore oppure no, permette di sostituire l'errore ad esempio con uno spazio "" (cella vuota).

Bene ora, queste funzioni sono da mettere insieme in modo da ottenere il primo effetto voluto: Isolare gli indirizzi email.

Visto che la funzione finale sarà il risultato di tre funzioni annidate, parto dall'interno verso l'esterno:

Funzione RICERCA

Opto per questa funzione tra le due citate in precedenza:

Ora devo pensare a qualcosa da cercare all'interno delle singole celle che accomuna tutti gli indirizzi email. Cosa più che il carattere "@" che ne è il simbolo stesso?

Nella cella B1 digito dunque: 

=RICERCA("@";A1)

funzione ricerca

La funzione ricerca, così immessa, cercherà la posizione del carattere "@" all'interno della cella A1. E' ovvio che da solo non basta, ma se il valore restituito è un numero, vuol dire che nella cella A1 è contenuto un indirizzo email. E' già un progresso no?

Per continuare ho bisogno della...

Funzione SE

...per capire cosa deve essere inserito nella cella B1. Mi spiego meglio:

  • Se nella cella A1 è contenuto un indirizzo email, deve essere riportato così com'é nella cella B1.
  • In caso contrario, la cella deve essere vuota (" ")

Con la funzione SE è presto fatto:

=SE(RICERCA("@";A1);A1;"")

funzione se

Il risultato è garantito laughing. Il problema si presenta quando, nella cella A1 non vi fosse un indirizzo email e la funzione RICERCA non trovasse il carattere "@". A questo punto, verrebbe generato un errore e per tutte le celle seguenti dove si verificasse lo stesso inconveniente, avremmo stampato "#VALORE".

Per ovviare al problema e inserire comunque "" in caso di errore generato da RICERCA, ci facciamo aiutare dalla...

Funzione SE.ERRORE

Annidiamo quanto fatto fin'ora come primo argomento della funzione SE.ERRORE. Il secondo argomento sarà "".

Modificate come segue la funzione contenuta nella cella B1:

=SE.ERRORE(SE(RICERCA("@";A1);A1;"");"")

funzione se errore

Fatto!!! laughing

Ultimi passaggi

Manca solo propagare la nostra funzione per tutte le celle contenute nella colonna A dove sono i nostri indirizzi email e il resto dei dati da scartare. Per farlo, usate il riempimento automatico: Con il mouse, dopo aver selezionato la cella B1, puntate sul suo angolo inferiore destro. Ora trascinate verso il basso.

Il risultato, è la colonna desiderata con solo gli indirizzi email, finalmente separati dal resto dei dati spuri inseriti dal cliente.

La colonna B conterrà le formule e non i dati reali mostrati. Se vogliamo dunque avere i soli dati, non ci resta che copiare tutta la colonna B dopo averla selezionata, selezionare una colonna vuota e fare Incolla speciale > Valori.

Ora mancano da isolare il resto dei dati dagli indirizzi email. Per sapere come farlo, leggete qui:

Excel - Isolare i dati di una colonna togliendo ciò che non serve


Se hai gradito l'articolo, condividilo, basta un click!

Aggiungi commento


Codice di sicurezza
Aggiorna

  • logo prontopro
  • logo boutique serramento
  • koilab japan and tropical fish farm
  • Trasloco economico - gruppo Arco Traslochi
  • logo flash pulizie
  • logo revolution
  • logo planetkoi small
  • logo finiture
  • ick logo template
  • montaggio mobili trento

Realizzato da: Daniele Gagliardi
Viale Monache 3 - 38062 Arco - TN
- Contattami -

Per essere più facile ed intuitivo, il blog fa uso dei cookie, piccole porzioni di dati che consentono di capire come gli utenti navighino e ne visualizzino le pagine. I cookie non registrano alcuna informazione personale sull'utente ed eventuali dati identificabili non verranno memorizzati.