Joomla! - Multisites WSOD

google-plus Scritto da . Postato in Joomla!

Il componente multisites si installa attraverso un pacchetto che si scarica dal sito jms2win previo acquisto.
La versione attuale è la 1.3.37 full.
Una volta installato il componente da backend vi informerà che ha bisogno di installare delle patches, cioè files che servono per innestare le funzionalità di multisites nell'installazione di Joomla!
Una volta effettuato il check patches e successivamente installate, multisites sarà completamente funzionante.
Tuttavia nel fare questa operazione, consiglio di effettuare prima un backup del sistema.
Infatti è successo che a causa di qualche aggiornamento e/o patches il sistema è andato in WSOD senza nessuna sorta di errore a dare indizi sul perché o su come risolvere il problema.
Dopo l'aggiornamento alla 1.3.37 e l'installazione delle patches 1.3.33 il risultato è stato questo.
L'installazione su sever locale non ha dato questa sorta di risultato.
Il trasferimento del sito remoto (master) in locale ha dimostrato che non è multisites a dare problemi.
A tal fine, prima dell'installazione di multisites, controllate i requisiti e che il vostro server, versione di PHP e dei componenti non siano in conflitto.
In tali casi è comunue buona norma tentare di disattivare il componente multisites. Ciò è semplice in quanto basterà all'interno della cartella includes/ creare un file vuoto con nome multisites_disable.php e successivamente rinominare la cartella installation/ che come ben sapete non va d'accordo con una normale installazione di Joomla! per motivi di sicurezza.
Se ancora non aveter risolto con il WSOD, evidentemente non è un porblema di multisites.
Tuttavia, una soluzione al problema WSOD riscontrato in questo frangente, lo abbiamo trovato commentando la seguente linea di codice nel file includes/multisites.php:
if ( class_exists( 'Jms2Win_Geoloc'))  { Jms2Win_Geoloc::intialise(); }
Sembra quindi che l'errore sia stato generato dal sistema geolocator di multisites coadiuvato ovviamente da qualche configurazione del server in conflitto.
Commentata la linea in questione il sistema è uscito dal WSOD.
 
Da recente aggiornamento, l'assistenza del prodotto ha avvertito che non hanno ancora testato la versione di multisites con PHP 5.5; E' quindi tenere conto di questo se si vuole gestire i propri siti con l'ausilio di questo componente.
 

Se hai gradito l'articolo, condividilo, basta un click!

Aggiungi commento


Codice di sicurezza
Aggiorna

  • logo prontopro
  • logo boutique serramento
  • koilab japan and tropical fish farm
  • Trasloco economico - gruppo Arco Traslochi
  • logo flash pulizie
  • logo revolution
  • logo planetkoi small
  • logo finiture
  • ick logo template
  • montaggio mobili trento

Realizzato da: Daniele Gagliardi
Viale Monache 3 - 38062 Arco - TN
- Contattami -

Per essere più facile ed intuitivo, il blog fa uso dei cookie, piccole porzioni di dati che consentono di capire come gli utenti navighino e ne visualizzino le pagine. I cookie non registrano alcuna informazione personale sull'utente ed eventuali dati identificabili non verranno memorizzati. La nostra Privacy Policy è cambiata: Ti invitiamo a prenderne visione. Oppure visiona la nostra Cookie Policy: